SolidRio

MrPLC Member
  • Content count

    59
  • Joined

  • Last visited

Community Reputation

1 Neutral

About SolidRio

  • Rank
    Sparky

Profile Information

  • Country Kazakhstan
  1. MX OPC

    Mitsubishi representative has answered to me: "There is no such restriction in MX OPC Server DA and the program allows you to create more than 10 connections."  I am not sure that "allows" equals "works reliably". I don't have so many PLCs right now to test it. Hope someone from here already has experience with this question and will share it.
  2. MX OPC

    Hello everyone.  Quote from "MELSOFT MX OPC Server UA Version 3 Operating Manual": That means i won't be able to connect more than 10 PLC to this OPC? If so, why that number so low? Do MX OPC DA has same restriction (in manual no word about this).
  3. GOT and OPC

     Yeah, but it leads to the first question of my topic about how to connect GOT and OPC 
  4. GOT and OPC

    I will repeat, that factory equipment at maintance, so there are not that much signals changing at the time and many steps is skipped in program, but result: Actual Scan Time: 152.9 ms Minimum Scan Time: 143.3 ms Maximum Scan Time: 214.2 ms But with all of this Channel Diagnosis shows me that latency about 6s (1 GOT, 2 SCADAs). I will repeat test tommorow, when all equpment will be in work so maybe some of numbers will change.
  5. GOT and OPC

    I have 2 cases.  1. FX3U-ENET have 2 GOT (Melsoft Connection) + 2 SCADA connection (TCP/Unpassive/Send/Procedure exist(MC)/Disable/Confirm/Port Number). That case is working not that bad, latency is about 750ms-1.5s (I watching in channel diagnosis in WinCC, but latency in WinCC and on GOT almost same). Latency not that bad mostly because not huge amount of data sending. Delay time is not set in GT Designer (0 ms). 2. FX3U-ENET have 1 GOT (Melsoft Connection)+ 2 SCADA connection (TCP/Unpassive/Send/Procedure exist(MC)/Disable/Confirm/Port Number). That case pretty bad. Latency about 3-6s. There are a lot of data and soon will be another GOT (so another Melsoft connection). Delay time is not set in GT Designer (0 ms). Right now plan to make MX OPC UA/DA (whatever) and put SCADA connection here. But i had idea to add GOT there too. But i am open to another solutions 
  6. GOT and OPC

    SoftGOT isn't the thing i needed, sadly. I already have working project with FX3U-ENET and multiple GOT panels that occupied almost all of available Melsoft Connections. And i was thinking what if i would connect FX3U-ENET to OPC and then connect OPC to multiple GOT. Because of a lot of GOTs requests - module is working quite slow and with the idea i described before i want to solve that problem.
  7. GOT and OPC

    Hello everyone. Is it possible for GOT(for example 1695-X) to take data from MX OPC UA or DA? I havent found anything on that topic in manual, maybe someone have experience in that case. As far i know it possible to take data from GOT to OPC (OPC have driver for it), but i never tried it and i need opposite data flow .
  8. FX5U - High-speed counter+encoder

    I didnt control a servo with encoder in mentioned post. In my case it was just encoder+plc for measuring. For servo you need positioning module (like FX5-40SSC-S), but you must check compatibility between servo and module.  
  9. Reading from FX3U error message

    Haha, i almost wrote you answer when i got same error (while testing your case) as you. So why do you have this error. When you working with FX3U and GX Works 2 you can download "Symbolic Information" into PLC. That means you can upload project in same "view" as you have in "Structured" or "Simple with labels" project (with all labels/FBs and etc). With Symbolic information you also downloading "Program File" ( https://prnt.sc/odxpot ) that contains "Simple Ladder" code. And if you download Structured or Simple Ladder with labels in PLC and after download only "Program File" from any other project over it, and after you will try to upload from PLC you will get with message. This means "Program File" and "Symbolic information" dont match.  One thing is bothering me. You dont have selection "Program File" (like here  when i got this message - https://prnt.sc/odxxqy ) in upload window. Which version of GX Works 2 do you have (i have 1.577B)? To upload actual program that works in PLC you should download "Program File". And its impossible to download "Symbolic Information" without "Program file" and PLC cant work without "Program File" so it must be there.  
  10. MX OPC Server DA/UA

    Problem is configuration tool of mx opc it self cant connect to opc.
  11. MX OPC Server DA/UA

    I am trying OPC servers from mitsu (never worked with them before). With UA version i have no problem. When i configured connection in DA server and start "Monitor view". I always got "Cant connect to OPC server". Reinstalled. Installed another version (7.02, 6.10). But problem the same.  I've installed on another laptop with the same system (7 x64), but without many plc soft here (only gx works 2 and gx developer) and it works without problem. I thinking some soft is blocking it. Maybe someone faced this problem before. p.s. Already second topic in one week with asking for a help, god....
  12. High speed counters

    As far as i know - you cant simulate high speed counter. At least when i tried - i failed. P.s. A little bit hard task for first plc project.
  13. FX5U and Encoder project

    Your post made me think all evening after work. I got it. And it seems moving encoder on motors shaft in first project helps in that way - more pulses on 1mm of production - scan time delay affects less on error, cause if i wrong count 250-500 pulses, its only 1-2mm, but if i use the wheel - 250-500 pulses - its already 75-150mm.  Next time i will fill mitsu servos, amps and that module into that type of project. And make this sh*t work without error in distance. Really thank you for your effort in this question. 
  14. FX5U and Encoder project

  15. FX5U and Encoder project

    Hello everyone. I need to share my thoughts with someone. I already have 2 project that’s includes machines like flying saws (that moving with production line and cut) and I faced some problems. Maybe someone will share their experience. 1 project: Production line that creates sandwich panels. At the end of line staying flying saw which moving by servo. As a distance meter was 1000 HTL push pull encoder with 300 mm circle that moving on sandwich panel. I used FX5U plc. Connected channel A and B on X0 and X1. Made High speed I/O Ch1 with 2 phase 1 multiple. We put 2 1,5k Ohm on both X0 and X1. Encoder cable shield was grounded. Program was like pulses*ratio=distance. Distance =>Setpoint -> Cut. And then started something random. Every start of line error between setpoint and real distance of panel was different. In one start there was error like 2-3 mm. After a day maybe, when they start line different start to be like 10mm or another. They had to increase setpoint every time. We checked everything encoder circle, its rotating on panel, all mechanicals things. Nothing helps. We decided that cause was the temperature in room. In place where encoder stayed sandwich panel was right after heating process and metal decreases in length right after saw cut it. So we put encoder on motor shaft which pull material. So now we have something like 250 pulses on 1 mm of production (before was 3.33333) and dont depend on real material. And that’s helped. Error was stable 1-2 mm.   2 project: Production line that creates plastic pipes. Flying saw at end of line. Encoder 1250, circle 500 mm. FX5U, X0 and X1. 2 phase 1 multiple. Resistance and ground. Program same. At the start was multiple random difference errors like 20-30 mm. Accidentally we noticed that our resistance (0,25 watt) were really hot. We cut them. And all started to work properly, but… Difference between setpoint and real pipe length was something 70mm. So they want 9,72 meter pipe and for that need 9,79 setpoint. Error was stable and they seems ok with that. But on another day when we left city – they started another orded with thicker pipe and to get 9,72 pipe they need to put 9,82 setpoint. They still ok with that, but I am not. Maybe I something missing, but encoder that rolling on material is just don’t work with me. How to make precise cutting in this type of projects? Speed synchronization between line and saw is ok, cause cut is clean and on different speeds – same error. Guys, help me.