dunc

MrPLC Member
  • Content count

    104
  • Joined

  • Last visited

Community Reputation

7 Neutral

About dunc

  • Rank
    Sparky

Profile Information

  • Country United Kingdom
  1. GOT 2000 scripting?

    brilliant, that explains it then. i guess when you use a 60 second sampling time, it is running the script once every minute so it doesn't time out. that does restrict its use somewhat, but at least i now know the limitations.   thanks
  2. GOT 2000 scripting?

    looks like the while loops time out after a time. if you have 10 seconds before you break out of the while loop, its fine. when i increased it to a minute, that gives up and appears to do nothing.   this rings true with my other more basic bit of code i tried.
  3. GOT 2000 scripting?

    previously i have just controlled it from the PLC, but after moving over from the E-series terminals to the GOT, i thought it would be nice to keep the same logout control done from the HMI itself to keep things neat. i have got something that works, but whilst getting that to work, found that the 'while' statements are not really working as expected.
  4. GOT 2000 scripting?

    tried this basic script and it works, but only for a short period of time, then it stops working? while ([b:GB200] == 1) { [s16:GD200] = 10; }   this is very odd?
  5. GOT 2000 scripting?

    the GOT turned up about an hour ago (i was using a GT23), so gave it a try myself and got the same result. like you say, it appears the 'while' loop is not working at all. 'if' statements are fine for alot of situations, but the 'while' statements should still work!? perhaps 'while' statements do not work in project scripts for some reason?
  6. GOT 2000 scripting?

    i have only been using the simulator, so suspect that could be a potential issue. i have ordered the screen for the project, but it hasn't arrived yet. if you have the chance to test it, that would be appreciated.
  7. GOT 2000 scripting?

    there are object scripts, screen scripts and project scripts. i used this script as a project script so should run constantly. the second script i posted functions perfectly fine, i just cant see why i couldnt get it to work using "while" statements? on this occasion i got round it, but i may have an application where i cant just use "if" statements to achieve what i want!   hopefully someone will come along who has played around with them a bit more
  8. GOT 2000 scripting?

    managed to get it to work. i cant get my head around how the WHILE statements work. if i use IF statements only it works fine!? am i being dumb? anyway, this worked: if ([w:GD0] == 0) { [w:TMP0] = 5;} if ([w:GD0] > 0) { [w:TMP0] = [w:TMP0] - 1; if ([w:TMP0] <= 0) { [w:GD0] = 0; } }
  9. GOT 2000 scripting?

    has anyone used this and had much luck with it? i have been trying to do something relatively simple and am struggling. i simply want to add in a project script to log out a user after a set period of time. initially i tried it by trying to write to the data register in the PLC and this didnt work. I then tried managing it all within the GOT and it partially works, but if i fire the simulator up with the login level already there, it just wont work? below is the script i am using: //if login level above 0 or login above 0 and login time count at 0 if (([w:GD0] > 0) || (([w:GD0] > 0) && ([w:GD1] <= 0)))  { //set GOT seconds to login time count [w:GD1]=[w:GS7];} //while login level is above 0 while ([w:GD0] > 0) { //if 60 seconds elapsed if([w:GS7]-[w:GD1]>=60){ //set login level to 0 [w:GD0]=0;}}   i have tried lots of different iterations. i have tried using a 1 second sampling trigger point method as well as the method above with an ordinary trigger with no real joy. could it be me using the simulator causing the issue and i should get some proper hardware, or am i just being completely stupid? any guidance would be appreciated. thanks
  10. we don't tend to use SD cards, but that is a good one to remember for the future.
  11. in GX works; is there any way around reading a structured project from a Q series CPU if the symbolic data (which takes up loads of room) isn't downloaded to the CPU initially? with a simple project you can simply read the program straight to a new project and then work with it. this doesn't appear to be possible with a structured project? siemens and allen bradley can manage this without having a huge CPU for a relatively small program, why cant mitsubishi?
  12. adding signal???

    really odd one. day 3 of trying this and i had another look about. found a utility on the taskbar which allowed you to monitor and change point values. did this with the signal that i was having trouble with and this managed to change the signal. the SCADA button now works as it should? did i miss something when adding the button and me using that utility forced it to work?
  13. adding signal???

    this should be simple and i have done it before with no issues. i simply want to add a button on screen to turn a bit on in the PLC. i added the signal in the point editor and all the settings are the same as a button i have added before. i have added the button on the mimic, done a bit of script to control it as before. i have recompiled the runtime. if i try and use the button, the signal does not change in the PLC. if i force the signal in the PLC, the colour of the button will not change either. everything else works perfectly fine including the button i added in a month or so ago. any ideas what i have missed? im sure its something stupid!   many thanks Duncan    
  14. i wish, i am in a maintenance department. we barely have enough to keep things going, let alone spares to set up a test rig.  everything i do has to be on the live system!!! i have no station number issues when i put them all on the same network, so wouldnt have thought it would be that? did get a chance to get on it last friday as had issues with something else :(   will try again this friday!
  15. yes, everything is 192.168.x.x based. i am not using the gp.read instruction. the system is setup using a function block downloaded from mitsubishi that sets the ip address and the port information only. i am hoping it is something i need to fill in on the network parameter pages, just struggling due to my limited knowledge. having done some extra reading i have a few extra things i can try, only problem is i only get the plant on a friday evening as it is running the rest of the time. will report back on how i get on