MrPLC Member
  • Content count

  • Joined

  • Last visited

Community Reputation

1 Neutral

About AMI

  • Rank

Profile Information

  • Country Spain
  1. Fins commands through the cpu serial

    Hi I suggest you to use Multiway software to check .It's a very useful tool from Omron You can dowdload from this forrum: Best regards
  2. I've been checking your EDS and there are some "TODO"... it seems that it's not complete. I've seen, also, that the assambly value in the EDS is Assem1 and  Assem2, not 100 and 150 like you have in the program. May be you could try to change these values inside Sysmac or replace into EDS
  3. Hi I'd suggest you to start again creating two arrays of bytes and register these two new variable in the Ethernet/IP (removing the current ones). This is the basic configuration from Omron PLC. If it doesn't work, check if robot Ethernet/IP is enabled or something to change. I've seen, also, that the EDS is from less than two months ago, Maybe need to update your Robot to accept it..   [File]         DescText = "Meca500 robot EtherNet/IP controlling API";         CreateDate = 02-10-2020;         CreateTime = 10:00:00;         ModDate = 02-10-2020;         ModTime = 10:00:00;         Revision = 1.0;    
  4. Hi Try to change the Instance ID to Auto in both (inputs and outputs).  
  5. SFC Action Duration

    Hi Brickraid You can use the variable StepName.T.  In your example is FillMould.T (like this in your local program). If you want to use this variable in your main program you have to add before the program name ProgramName.StepName.T  
  6. Hi WKTilton Nice to heard that it was useful for you!!! I think that the reason is because with the setting ....Actual Position, when you get the Software Limit Error and you try to move to opposite direction, the axis is still outside limits, so the actual position is also outside range and you get the error again. Why it doesn't happen with the Hardaware limits? I don't know. But the most important is that you got the machine running as you need!!!
  7. Hi  Try to change (apply) this setting in the Axis Cofiguration. Let me know if this help you...