All Activity

This stream auto-updates   

  1. Past Hour
  2. Today
  3. Yesterday
  4. You're welcome. I learned those tips the hard way. One of my first tasks here (over 8 years ago) was converting an old PanelView 1400 (a CRT HMI that was a predecessor to the Panelview Standard) to a PanelView Plus. It connected to a PLC-5 over DH+. It took me a while to figure it all out using just the manual we had for RSView 32 version 4 (which became FT View Studio at version 5, I think). Unfortunately, the glitches and gotchas I had to work around back then are still there at v8.2.
  5. Thanks for the added tips Joe.
  6. FX1S output failure

    This is from Fx1S hardware manual for relay output type Response time  (approx.) OFF ➔ ON 10ms ON ➔ OFF 10ms
  7. Here's another tip. If you copy/paste a bunch of objects from one HMI project to another, and if the device shortcuts are named differently, you will have trouble. Also, if you change the name of the device shortcut in the communications setup, it will NOT change the name in your display objects! To remedy that, you can select all of the objects on a display screen by pushing ^A, then open the tag substitution dialog by pushing ^R. You can search for any text and replace it with any text: In this dialog, I can enter Ink_Detect in the "Search for:" field and enter Ink_Detect_D in the "Replace with:" field if I change my device shortcut name to Ink_Detect_D. This is also a handy dialog to use to see the tags and expressions that are used on that display. You can just scroll through the list looking for misspellings etc. There are other gotchas I learned the hard way. You can be doing everything perfectly correctly and it still won't work, until you reboot your PC. Then it "magically" starts working. If everything looks right, like, " should work, darn it!!!", try rebooting the PC. Especially, especially, especially if you're making changes to the device shortcut or communications settings. I've had countless annoyances working with these HMIs when I made a change to the communications and had to jump through otherwise pointless hoops to get it working again. I've even seen where I could run the project in test mode and it's fine but when I compile & download the runtime to the HMI, it doesn't work. Until I reboot the PC and re-compile the runtime file. Then it works, without changing anything else. As an example, I decided to test what I just outlined above by changing the device shortcut name to verify that it didn't change it in the object properties. Then I changed it right back and nothing would communicate in test mode. I shut down/restarted View Studio, same result: no comms to the PLC. Then I rebooted the virtual machine, opened View Studio, and tested it and it worked perfectly. If in doubt, and you think you have it right, first close and re-open View Studio. If that doesn't fix it, reboot your PC.
  8. Here are some screenshots of what I'm working on now: First, here's the Communications Setup dialog box: The device shortcut here is "Ink_Detect" and it points to the MicroLogix 1400 at Next is the Connections tab of the properties of a multistate indicator that's tied to the address N7:70: Note the syntax with the colons and square/curly braces. Your device shortcut name is embedded in there. If you click the "..." button under "Tag", you'll get the tag browser: The project name is Ink_Detect_D, which is the top level of the browser window. Ink_Detect is the name of the device shortcut. This is not final and I'll end up changing the names once it's closer to being done and I know exactly which line it'll end up on. If your shortcut is configured correctly, and the PLC is ping-able at the IP address in the design (Local) tab of the shortcut, clicking "Refresh All Folders" will populate these folders. The address I need for the multistate indicator is inside the N7 file, expanded above. If you use the "..." button to open the tag browser, you can just double-click on the address you want and it will automatically add the punctuation and syntax it needs.
  9. FX1S output failure

    If the led output light is not coming on when in pulse mode then something is inhibiting it in the program. I think you are wrong with the pulse timing, 3msecs wouldn't be enough time to energise the external relay.   You have to find out the correct procedure to run in pulsed mode  
  10. I'm not clear on this step, I don't see those options in FTView or RSLogix 500. This sounds like my issue then... edit: Oh, I see my mistake now. Thank you so much for both your help. The device shortcut had to be named cpu4 because the diagnostics/error log at the bottom of FTView was spitting out some message about not being able to find [cpu4]::N7. This is all new to me, I won't be forgetting this!
  11. Awesome, that's good to hear. We're all at v8.2 (2 laptops for the maintenance folks and 4 for engineers). Our firmware versions range from 5.x to 9.
  12. I think it's this one, but always grab the latest and greatest. FactoryTalk View Patch Roll-up August 2018 Integrator on this side.  We have a recent project where several engineers were working.  The initial guy responsible for HMI development was using v10, yet the PV+6 was at fw8.2.  Everyone else was at v8.2.  That guy moved on to another project, I'm suddenly in charge and I was a v8.0.  Found the patch and was able to upload MER at fw8.2 and restore to my v8.0.  While reading the release notes, I realized that they added that patch concerning db conversion.  So I tested it, successfully, on older projects at v5 and v6.
  13. Cool. We have so much on our plates, we haven't been able to investigate that at all. Right now, we're avoiding anything that would make it more complicated to keep the machines running and make the upgrades we're being asked to make.
  14. Joe, on your database conversion issue, there are patches to FTView that now handle all of that for you.  You can take an APA or MER from older versions and it automatically converts to the new version including the database.
  15. My VM is Windows 7 32 bit. One of the reasons View Studio is isolated on its own is that there's an involved process to convert the database files to work on 64-bit Windows that we haven't been willing to tackle yet since we have several dozen projects and the last thing we need right now is to have some on 32-bit and others on 64-bit. There's something going on with either our group policies (rigidly controlled by IT) or our network switches (also rigidly controlled by IT) that we can't "autobrowse" and find anything. The Ethernet/IP driver in RSLinx Classic very rarely works; we have to use Ethernet Devices. Logix 5000 devices use Ethernet/IP while the older SLC and PLC5s use a different protocol that may not work with autobrowsing. There are several members on here with much more networking experience than I have who can clarify that difference. The shortcut name can be anything (as far as I know) but it has to be in each display object's configuration exactly right with the right numbers and placements of square and curly braces, periods, and colons. It's a royal pain if you try to do it manually but is pretty straightforward if your local device shortcut is right and you can browse the PLC...which brings us back to your original question. If you open an object on a display, go to its "Connections" tab, and click the "..." button under the "Tag" column to open the Tag Browser. Click "Refresh All Folders". Your shortcut name should show up as a folder with an "Online" folder under it. The "Online" folder should contain a bunch of stuff. In a 5000 processor, it would be the tag names. In a 5/500 processor, it will be a folder for each data file. If that doesn't populate, there's something wrong with your device shortcut.
  16. The Device Shortcut name can be anything.  I would suggest [PLC] or [SLC] to make it easy.  Then the question becomes how your various display objects are configured.  Meaning, did you construct a tag database or direct tagging via offline PLC program or online connection to PLC. You might have to go into the tag database and add the Device Shortcut to the addressing and/or every object's connection. Joe, you might want to correct me on this one. I have VMs of most every Win OS with FTView (various versions) installed.  As for PB32, I have it only in a VM of Win XP, so not much help there.
  17. FX1S output failure

    I think, that Y0 is fine. You just control it the wrong way. You can not run relay output for just 3ms. I do not recall right now what is the ON time for Fx series relay outputs, but i assume 10-12ms. It is normal to get 24V if com0 is connected there and the load is on Y0 and it's other end to GND. You have potential trough the load when the PLC relay is open(Y0 off)
  18. Does the device shortcut name matter, I'm not clear its purpose? I have right-clicked on the Ethernet driver and added a device with IP in both the local and runtime tabs. And clicked apply to the previously mentioned device shortcut. I just noticed that if I make a 2nd Ethernet driver, it auto-populates with a lot of our equipment IPs. Except for the SLC that I am looking for, which I have verified again is active. As a side note, what version of windows is your virtual machine with FT View Studio. I have a laptop running Windows 7 64-bit which only lets me import a PanelBuilder 32 into FT View if I remote desktop into the W7 64-bit machine via my main W10 machine. I think it is because FT View maybe running in 32-bit mode over a remote desktop connection...
  19. You shouldn't need RSLinx Classic at all to get the HMI to talk to the PLC, assuming the PLC already exists and is programmed (I assume that's the case, since you can see it in RSLinx Classic). I have FT View Studio installed by itself on its own virtual machine with RSLinx Enterprise and NOT RSLinx Classic. If the PC you're using to develop the HMI project can ping the PLC, you should be able to browse the tags in the PLC from within View Studio once the device shortcut is set up correctly. We don't have any 5/05s in service, and only one on hand that's not in a rack and I can't put my  hands on it immediately, but I do have a MicroLogix 1400 on my desk with  PV+7 talking to it that works similarly enough I may be able to help you some... Can you share your View Studio project archive (it will be a *.apa file after you use the application manager to make an archive).
  20. Ok, so can you see the SLC Process in RSLinx? Forgive me, I haven't worked on a SLC in a decade.  Have to refresh my memory. Back in RSLogix500 you have to then pick the right path of the processor.  From the Menu, select drop down of Comms.  You can choose System Comms or Who's Active.  This calls up an RSWho of your currently configured RSLinx.  You then drill down to the processor and highlight it, by clicking on it.  The RSWho should respond by changing the greyed out buttons for Online, Upload and Download.   Choose whichever applies to your situation. Opps, Joe's response below is better.  Thought you were talking about going online with PLC. In FTView, you need to build the ethernet driver and the rack with the IP address.  In the lefthand pane you need to configure Device Shortcut, hopefully duplicate the name from the old panelview, then point it at the SLC processor in the righthand window and apply.
  21. FX1S output failure

    Hi RON_S I made a mistake the output light does not turn on on the Y0 output when in pulsed mode. But it does turn on when i select constant mode. When i go back and select pulsed mode and measure between Y0 and Com0 I have 24vdc. I am no confused if i have 24vdc at this then should it not be running? When i link it out again with a piece of wire between Y0 and Com0 the paddle runs but am i not just mimicking the constant signal by doing this?
  22. Is there anything that I need to configure seperately in RSLinx Classic then? I have added the ethernet drive with the correct IP address to the PLC but I am still not able to connect when testing the converted HMI. I don't have something configured properly, but I can't figure out what. I can ping the IP, it is valid. I have RSLinx Enterprise drivers setup in both the Design (Local) and Runtime (Target) tabs.
  23. FX1S output failure

    And in pulse mode you turn on Y0 for 3ms ?!
  24. FX1S output failure

    There's your answer then :) You can put a volt meter on the Y0 terminal and check whether there is anything there when it pulses. If it's missing or intermittent then the output internal relay is failing.
  25. FX1S output failure

    yes it is
  26. FX1S output failure

    Is it a relay output?
  27. Load more activity