All Activity

This stream auto-updates   

  1. Past Hour
  2. RSLINX in excel

    BTW- the IOM Builder spreadsheet came about because I needed a way to map IO to tags that was quicker than typing 400-500 or more text strings. Mapping tags lets me build a program before I even know where the wiring lands in the PLC. Everything is addressed to a tag and the IO is mapped to it. The spreadsheet turned a day or more of work, that had errors, into a few minutes. I have another one for mapping analog data. And another one for documenting analog data. Also, if you map the IO they (the customer) can change their mind all they want. If they move wiring around, I just change a value in the map tag. 
  3. RSLINX in excel

    Turn this - =RSLINX|MC!'Database_fifo[0].Motor_rpm, L1,C1' into a formula Deleted the formula because it was a crappy example You know... I think this will work better if I give you a working example See the attached spreadsheet Click on the Motor Definition Tab, then go look at the way that I assembled that data into a string of data in the Motors with Start Stop IO tab. You copy the results of the formula using paste as value. IOM Builder Rev 2.xls
  4. RSLINX in excel

    I'm not sure what's going on with the first one. For the second one, to get the string RKBF-355 into a single cell, you can do what you did with the Char() command, then concatenate the cell contents into a single cell with a series of "&" commands: A single-step formula would look like this: = Char(C8) & Char(C9) & Char(C10)...   ETA: Note: my cell references aren't the same as yours since I didn't type the numbers into the same fields as they are in your screenshot.
  5. RSLINX in excel

    Hi Guys! A have a problem with Excel and RS linx. I belive the communication is good. I just need a few tips, especially with excel. I have about 3000 dint value, and aI dont know how to put them in excel at once. Not one by one. THis is my first question. You can see the link: =RSLINX|MC!'Database_fifo[0].Motor_rpm, L1,C1' the next one is =RSLINX|MC!'Database_fifo[1].Motor_rpm, L1,C1' and =RSLINX|MC!'Database_fifo[2].Motor_rpm, L1,C1' and so on. I dont want to write the numbers like 3, 4 ,5 ...2560... So I hope you guys get it, sorry for the bad explanation. For this problem maybe exsiting some macro or something like that, I dont know. The second: there is some dint what is in decimal style, but acutall they are ascii, I know how solve that, with the char function, but I dont know how to collect it. Like on the picture, there is the numbers what I read from the plc, like 82 equal to R. But I want to see them in one cell. Like RKBF-355, I want them in a same cell. Unfortunaltely I cant solve it. At least until now, and I hope somebody know it by memory.    Thank you in advance!  
  6. Today
  7. Why not just go to View -> Variable manager.  Find the local variable in the program and then right click on it and move it to global.
  8. retired master electrician

    If ever i come in problem with electrical appliances and need an electrician, can i call you for help?
  9. PLC Keyence - KRC4 via profinet

    1. decide which role each node will play (normally PLC is master, KRC is slave. when connection also includes safety signals, PLC must be master) 2. import GSDML file of the node acting as slave int configuration software of the master 3. make sure both master and slave have matching network settings, shared IO size and exact same spelling for slave name.
  10. SLC 504 and Prosoft AN-X2-AB slow

    I don't think the lag is to be expected at all. We have several places in our plant where we're using an AN-X2-AB-DHRIO to connect an Ethernet/IP-only HMI to a DH+-only PLC. We're also using the same type of module to connect our programming PCs to the PLCs for programming/diagnostics. As a test, my colleague configured a gateway module to connect 3 DH+ PLCs (PLC5, SLC 5/04) to 3 different PanelView+ HMIs and used it to go online with each PLC, all with no significant lag. Unfortunately, I don't have any ideas of what to check, just that I would not expect to see the behavior you're seeing.
  11. How to download omron scada

    Hello sir How to download omron scada 
  12. Hello We have a machine called a tweedy mixer in a bread plant. It has 3x  SLC5/04 plc's and 2 Xycom industrial pc's running wonderware intouch 7. The system communicates over DH+. The issue  i have is that the DH+ network is obsolete and we require a new Industrial pc to replace a broken unit. unfortunately you cant not buy an industrial pc with DH+ anymore so we have had to use a prosoft AX-X2-AB to convert from DH+ to Ethernet.   This network seems to lag though and i would say the commands take around 10 seconds to reach the plc through the prosoft converter.  unfortunately that lag renders the machine completely useless. i have used multiple PC's and the issue hasnt resolved it self. I am wondering if there is anything i could check or do to try speed up the network. or if this lag is to be expected. I would also like to know if some one else has a similar system and if its running perfectly.  I look forward to your reply  Trevor
  13. To my knowledge, it is not default. I checked it before snapping this screen shot. Be aware, when I checked it, I lost my existing comments. If you have a lot of them you may want to perform an export or save a backup project.
  14. Thanks.  I'm pretty sure use global comment is the default, so I don't know how/why I unchecked it.
  15. Something with my Mitsubishi happened...

    This is a forum for Mitsubishi factory automation components not cars...
  16. Hi all,I'm trying to diagnose a problem with my Mistsi L3E fitted to a Volvo mini excavator (271 I think)..Anyway after some hard starting and I think loss of power (stalls whilst digging etc.) , I've pulled the engine out to investigate.I've looked through a few really good threads on this site about this engine, and I think there are a good few experts around here that know thier stuff, so thought I'd try a couple of questions..1) On checking the compression (whilst running the starter) I get around 210psi. This was pretty similar on all cylinders..From the L3E Manual it shows the pressure should be 413-455psi, so according to this I'm way off.Does this pressure reading from the manual sound right ? It sounds quite high to me (the compression ratio of the enigne should be 23-1, so maybe should be more like 338psi (14.7 * 23 = 338) ?I'm not sure I'm checking the pressure reading I'm getting against the correct value..2) It seems the pressure is down whichever value I check against,so I'm trying to find out why.The cylinder widths look pretty correct at 76mm, or thereabouts (within limits).I can't see any cracks etc.The rings were the next obvious thing, 1 measured gaps of:No 1 - 0.7mmNo 2 - 0.55mmOil - 0.55mmI'm not sure if this is a problem ; the manual gives the 'Standard' gap as 0.15 to 0.30mm, and a service limit of 1.5mmIt only recommends replacing the rings if they are above the service limit.What is the difference between the Max 'Standard' gap and the Service Limit ?Mine at 0.7mm are above the Max Standard Gap, but below the Service limit. Would you think they need replacing ?Probably more to the point is do you think that even though they are below the service limit, they could be accounting for the loss of pressure (@200psi according to the 413psi figure in the manual) ?Would this 'extra' gap or wear account for this much pressure loss ?I did clean up 1 set of valves and seats and re-tested, I got about another 20-30psi, so I reckon with a good valve cleanup each cylinder would probably give around 230psi.. Still pretty low, would the ring gap account for this ?Thanks for any help!
  17. Yesterday
  18. boa noite a todos! Eu preciso de uma licença Tempo de execução de 300 pontos, alguém tem uma p vender?
  19. Micrologix 1100 1762 L16BBB

    You will get an error code until a program with the card listed in the ok list is downloaded. Be sure to follow all configuration directions.
  20. Vijeo Citect - write to tag - error

    boa noite a todos! Eu preciso de uma licença Tempo de execução de 300 pontos, alguém tem uma p vender?
  21. boa noite a todos! Eu preciso de uma licença Tempo de execução de 300 pontos, alguém tem uma p vender?
  22. Vijeo Citect - write to tag - error

    boa noite a todos! estou precisando de uma licença Run time de 300 Pontos , algum tem uma p vender?
  23. Vijeo Citect

    boa noite a todos! estou precisando de uma licença Run time de 300 Pontos , algum tem uma p vender? 
  24. Kinetix 6000 servo MSO error

    Hi ABlearner. Welcome to the forum. The first thing to check is the Motion Error code housed inside your Motion Instruction. Open your tag structure after the ER has occurred and navigate to yourMSOtag.ERR and feedback the error code....     Regards Daniel.
  25. Beckhoff TC3

    Very cool!
  26. TwinCAT 3.1 Sony Camera Control

    New to the forum here, but have been a lurker for awhile.  I've been using TwinCAT 2 and 3 for several years now, and I'm pretty familiar with using them for most applications in my world.  I'm working on a personal project right now where I want to achieve wireless control of a Sony Camera.  Sony has developed an API that allows this through usage of HTTP POST with JSON.  I'll admit this is totally outside my wheel house and I'm uncertain on the best way to achieve this through TwinCAT 3.1. Beckhoff is developing a library currently, but that won't be released until the last quarter of this year.  Sony shows sample code but its for Smartphone OS platforms.  I'm wondering if I can integrate a Python project into Visual Studio somehow and then link my data structures some how?   For those that are curious the control of the camera is for syncing my photos to a stepping linear motion. I'm using a Beckhoff EL7211 servo setup to run a Festo linear slide.  The camera will be mounted to the slide and I plan to use it mainly for moving time lapse photography.  I'm lucky that we had this hardware just laying around work :).   Video of slide system https://www.youtube.com/watch?v=BEHtblNpLK4 Sony API https://developer.sony.com/develop/cameras/ Beckhoff library https://www.beckhoff.com/TF6730/  
  27. Kinetix 6000 servo MSO error

    Hi Guys!   Anybody Can help me ? I have a kinetix 6000 servo, and that axis dont want to go in home position. There is an MSO instruction, but the ER bit is active.  What should I do ? What would be the problem?    Thanks in advance!
  28. Load more activity